본문 바로가기
KERD
논문KCI 등재

인터넷 표준 확장을 통한 사용자 중심의 악성메일 식별 향상에 관한 연구

A Study on Improving User-Centered Identification of Malicious e-Mails through Internet Standard Extensions

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류학제간연구

초록

악성메일 공격은 피싱, 사회공학, 악성코드 등 다양한 위협과 관련이 있으며, 차단기술이 발전하고 있지만 공격과 피해의 총량은 지속적으로 증가하는 추세로, 진화하는 다양한 종류의 위협에 완전한 대응을 하는데 한계를 보이고 있다. 기존의 경계기반 보안 모델은 악성메일 공격을 효과적으로 방어하는데 실패하고 있다고 본다. 본 연구는 이러한 문제를 개선하기 위해 제로 트러스트 보안 모델에 기반한 새로운 보안 모형을 제안한다. 이 모형에서는 제로 트러스트를 내재화한 사용자가 중심이 된다. 그리고, 이메일 검사정보를 표준화된 헤더로 확장하여 이를 이메일 클라이언트가 사용자에게 실시간으로 제공함으로써, 사용자가 모든 이메일을 잠재적인 악성메일로간주하고 정확히 검증할 수 있도록 지원한다. 또한, 확장된 헤더 정보를 통해 이메일 보안 게이트웨이와 사용자 간의 협력을 촉진함으로써 악성메일의 차단 및 사고 예방을 강화하도록 한다. 이러한 접근은 사용자 중심의 보안 인식 정착과 더불어, 악성메일로 인한 기업 및 개인의 피해를효과적으로 줄이고 나아가 보다 안전한 인터넷 환경을 조성하는 데 기여할 수 있을 것으로 기대한다.

Abstract

Malicious email attacks are associated with various threats such as phishing, social engineering, and malware. Despite advancements in blocking technologies, the overall volume of attacks and the resulting damage continue to rise, highlighting the limitations of current defenses against the evolving nature of these threats. Traditional perimeter security models are increasingly ineffective in countering malicious email attacks. To address these challenges, this study proposes a new security model grounded in the core principle of Zero Trust security: “Never Trust, Always Verify.” In this model, users are central, with Zero Trust principles embedded in their interactions. The model extends email inspection information into standardized headers, which are then provided in real-time by email clients to users. This allows users to treat every email as potentially malicious and to verify them more accurately. Additionally, by enhancing collaboration between email security gateways and users through these extended headers, the model strengthens the prevention and blocking of malicious emails. This approach not only improves user-centric security awareness but is also expected to effectively reduce the damage caused by malicious emails to both organizations and individuals, ultimately contributing to a safer internet environment.

참고문헌 (57)

  1. 과학기술정보통신부, "제로트러스트 가이드라인 1.0", ~ (2023)
  2. 김경철, "명의도용 및 이메일 해킹 무역사기 예방에 관한 연구", 무역금융보험연구, 23(1), pp.137~150 (2022)
  3. 김도우, "사회공학적 공격기법의 유형분류", 한국산업보안연구, 9(2), pp.9~21 (2019)
  4. 김보라, "보안교육 및 보안서비스가 조직구성원의 정보보안정책 준수에 미치는영향", 정보화정책, 25(1), pp.99~114 (2018)
  5. 박재혁, "인간의 감정 상태를 이용한 사회공학 기법 연구", 정보보호학회논문지, 25(4), pp.57~62 (2015)
  6. 손한기, "Rule 기반의 필터링 및 딥러닝 LSTM을 결합한 이메일 스팸 분류", 한국정보보호학회 2021 한국소프트웨어종합학술대회 논문집, pp.105~107 (2021)
  7. 신동천, "스피어피싱 메일 필터링 보안 기능 분석 : 기업메일 호스팅 서비스 중심으로", 융합보안논문지, 20(3), pp.61~69 (2020)
  8. 유지현, "악성 이메일 공격의 사전 탐지 및 차단을 통한 이메일 보안에 관한 연구", 전기전자학회논문지, 25(4), pp.672~678 (2021)
  9. 윤자정, "비주의적(非注意的)시각정보 처리를 고려한 미디어 공간 연구", 한국공간디자인학회논문집, 9(3), pp.123~132 (2014)
  10. 이도경, "AI를 통한 BEC(Business Email Compromise)공격의 효과적인 대응방안 연구", 정보보호학회논문지, 30(5), pp.835~846 (2020)
  11. 이상협, "Spear-Phishing(스피어피싱)의 산업보안관점에서의 위험성에대한 범죄학적 접근", 한국산업보안연구, 4(2), pp.303~337 (2014)
  12. 이선호, "산업망에서의 APT(지능형 지속위협)침투경로 분석 및 대응방안 고찰-스턱스넷 사례를 중심으로", 한국산업보안연구, 5(1), pp.221~253 (2015)
  13. 이용필, "국내 사이버 침해사고의 경제적 피해금액 산정", Korea Business Review, 24(2), pp.143~164 (2020)
  14. 이은경, "무역 산업에서의 비즈니스 스캠(Business Scam) 대응 문제점과 대책 방안", 한국컴퓨터정보학회 학술대회논문집, 24(1), pp.307~310 (2016)
  15. 이정민, "사용자의 행위 체계에 영향을 미치는 디자인심리 원리와 디자인 방법론에 관한 연구", 한국공간디자인학회논문집, 16(1), pp.179~194 (2021)
  16. 이준희, "스팸메일 모의훈련 현장실험을 통한 기업의 인적 취약요인 연구", 정보보호학회논문지, 29(4), pp.847~857 (2019)
  17. 이창무, "산업보안범죄와 박수이론", 한국경호경비학회지, 64, pp.9~30 (2020)
  18. 이태우, "악성 이메일에 대한 안전한 대응의 효과성 연구", Journal of Platform Technology, 9(2), pp.26~37 (2021)
  19. 정진우, "휴먼에러-휴먼에러의 개념, 발견 및 결과", 산업보건, 371, pp.32~40 (2019)
  20. 최선영, "지속가능한 경영을 위한 산업보안 거버넌스", 한국산업보안연구, 12(3), pp.137~168 (2022)
  21. The State of Email Security in an AI-Powered World. Research Report, "Abnormal Security", ~ (2023)
  22. Abroshan, H., "Phishing Attacks Root Causes", Lecture Notes in Computer Science, 10694, pp.187~202 (2018)
  23. Alkhalil, Z., "Phishing Attacks : A Recent Comprehensive Study and a New Anatomy", Frontiers in Computer Science, 3, pp.1~23 (2021)
  24. Al-Musib, N. S., "Business Email Compromise(BEC)Attacks", Materials Today : Proceedings, 81(2), pp.497~503 (2023)
  25. Phishing Activity Trends Report. 4th Quarter 2022, "APWG(Anti-Phishing Working Group)", ~ (2022)
  26. Cybercrime Thrives during Pandemic. Verizon 2021 Data Breach Investigations Report, "Burbidge, T.", ~ (2021)
  27. Ransomware Threat Rises. Verizon 2022 Data Breach Investigations Report, "Burbidge, T.", ~ (2022)
  28. Chen, J., "Composition Kills: A Case Study of Email Sender Authentication", Proceedings of the 29th USENIX Conference on Security Symposium, pp.2183~2199 (2020)
  29. FBI(Federal Bureau of Investigation), "Business Email Compromise", ~ (2017)
  30. FBI Internet Crime Report 2022, "FBI(Federal Bureau of Investigation)", ~ (2022)
  31. Feinler, E., "Email Innovation Timeline", Computer History Museum, ~ (2022)
  32. Ghafir, I., "Advanced Persistent Threat and Spear Phishing Emails", International Conference on Distance Learning, Simulation and Communication, pp.34~41 (2015)
  33. Gilman, E., "Zero Trust Networks: Building Secure Systems in Untrusted Networks" (2017), O’Reilly Media
  34. Heijden, A., "Cognitive Triaging of Phishing Attacks", 28th USENIX Security Symposium, pp.1309~1326 (2019)
  35. Hiransha, M., "Deep Learning Based Phishing E-mail Detection", Proceedings of the 1st Antiphishing Shared Pilot 4th ACM International Workshop on Security and Privacy Analytics (IWSPA), 2124, pp.16~20 (2018)
  36. The State of Cybersecurity 2022 Report, "ISACA(Information Systems Audit and Control Association)", ~ (2022)
  37. Krombholz, K., "Advanced Social Engineering Attacks", Journal of Information Security and Applications, 22, pp.113~122 (2015)
  38. NCSC(National Cyber Security Centre), "Business Email Compromise: Dealing with Targeted Phishing Emails", ~ (2020)
  39. Ncubukezi, T., "Human Errors: A Cybersecurity Concern and the Weakest Link to Small Businesses", Proceedings of the 17th International Conference on Information Warfare and Security, 17(1), pp.395~403 (2022)
  40. Reason, J., "Human Error" (1990), Cambridge University Press
  41. Stallings, W., "Comprehensive Internet E-Mail Security", The Internet Protocol Journal, 19(3), pp.2~30 (2017)
  42. Symantec Internet Security Threat Report, "Symantec", ~ (2018)
  43. Advanced Threat Research Report, "Trellix", ~ (2021)
  44. "트렌드마이크로, 업계 최초 인공지능 기반 이메일 사기 방지용 문체 분석 기술 선보여" (2018)[URL]
  45. "구글, AI로 스팸 99.9% 거른다...자동화로 생산성 제고" (2017)[URL]
  46. "고도화된 사회 공학적 공격기법, 사람을 겨냥하다" (2019)[URL]
  47. "인터파크 1,000만 고객 정보 유출 사건 분석... “완벽한 APT 공격 사례, 2차 피해로 확산될 듯”" (2016)[URL]
  48. "LG화학, 가짜 이메일 믿고 240억 날려…경영진 문책론 나와" (2016)[URL]
  49. "AI vs. Human Deceit: Unravelling the New Age of Phishing Tactics" (2023)[URL]
  50. "RFC 822 - Standard for the Format of ARPA Internet Text Messages" (1982)[URL]
  51. "RFC 6376 - DomainKeys Identified Mail (DKIM)Signatures" (2011)[URL]
  52. "AI 피싱도 인간에 근접… 생성형 AI 모델, 5분 만에 ‘설득력 높은’ 메일 생성" (2023)[URL]
  53. "RFC 7208 - Sender Policy Framework (SPF) for Authorizing Use of Domains in Email" (2014)[URL]
  54. "RFC 5321 - Simple Mail Transfer Protocol" (2008)[URL]
  55. "RFC 7489 - Domain-based Message Authentication, Reporting, and Conformance (DMARC)" (2015)[URL]
  56. "RFC 5322 - Internet Message Format" (2008)[URL]
  57. "RFC 6648 - Deprecating the “X-” Prefix and Similar Constructs in Application Protocols" (2012)[URL]

관련 논문AI추천

이 간행물의 다른 논문 (11건)