본문 바로가기
KERD
논문KCI 등재

IPv6 기반 동적 이동 네트워크에서의 안정적 통신을 위한 장애극복 메커니즘

Fault Tolerant Mechanism for Reliable Communications in Dynamic Multi-home IPv6-based Moving Networks

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

동적인 이동 네트워크는 이동 애드혹 네트워크로 서로 연결된 다중의 독립적인 무선 개인범위 네트워크를 갖는 이동 네트워크의 한 종류이다. 휴대폰과 같은 이동성을 갖는 장치들이 동적인 이동 네트워크를 위해 모바일 라우터로써 동작하기 때문에 트래픽 과부하, 신뢰성, 에너지 소비율과 같은 장애처리 문제가 존재할 것이다. 따라서 고성능의 동적인 이동 네트워크의 필수적인 이슈로 장애처리를 위한 메커니즘이 대두될 것으로 보인다. 본 논문에서 우리는 장애처리를 위한 방안으로 빠른 경로변경 메커니즘과 추가적인 게이트웨이 모바일 라우터 선정 메커니즘 등의 기술들을 제안할 것이다. 결과적으로 우리의 접근 방식은 이동 네트워크에서 모든 노드들에게 있어 더욱 신뢰성 있고 끊어짐 없는 연결을 보장할 것이다. 마지막으로 모의실험 결과를 통하여 전체 네트워크의 에너지 소모율과 패킷 손실률의 관점에서 제안된 메커니즘의 수행과 효율성을 보여줄 것이다.

Abstract

Dynamic mobile network is a kind of moving networks which has multiple independent wireless personal area networks interconnecting with MANET networking. Since a mobile device like a cellular phone can works as a mobile router for a dynamic mobile network, there are some fault problems related with traffic overload, reliability and energy consumption. And the essential issue of highly dynamic mobile network is fault tolerant mechanism. In this paper, we propose fast path redirection mechanism and candidate GMRs election mechanism in order to enhance fault tolerance. As a result, our approaches support more reliable and seamless connectivity to all the nodes in mobile networks. Finally simulation results show the performance and efficiency of the mechanisms in terms of energy consumption and packet loss.

참고문헌 (22)

  1. 김원태, "이종접속망지원모바일게이트웨이기술 개발 동향", 전자통신동향분석, 23(1), pp.33~43 (2008)
  2. "IETF MEXT WG"[URL]
  3. C. Ng, "Analysis of Multihoming in Network Mobility Support,IETF draft-ietf-nemo-multihoming-issues-04", ~ (2005)
  4. R. Wakikawa, "Experimentation of networked vehicle with multihomed mobile router", VTC-2005- Fall, 통권 : 1, pp.334~338 (2005)
  5. P. E. Engelstad, "Internet connectivity for multi-homed proactive ad hoc networks", IEEE International Conference on Communications, 통권 : 7, pp.4050~4056 (2004)
  6. S. Kashihara, "Path selection using active measurement in multi-homed wireless networks", Applications and the Internet, 2004. Proceedings. 2004 International Symposium on 2004, pp.273~276 (2004)
  7. S. H. Cho, "A dynamic load sharing mechanism in multihomed mobile networks", ICC 2005 16-20 May 2005, 통권 : 3, pp.1459~1463 (2005)
  8. E. K. Paik, "Load sharing and session preservation with multiple mobile routers for large scale network mobility", The proceedings of AINA 2004, 통권 : 1, pp.393~398 (2004)
  9. C.M.Huang, "A Novel SIP-Based Route Optimization for Network Mobility", IEEE JSAC, 24(9), pp.1682~1691 (2006)
  10. Q.Song, "Network selection in an integrated wireless LAN and UMTS environment using mathematical modeling and computing techniques", IEEE Wireless Communications, 12(3), pp.42~48 (2005)
  11. D. Johnson, "Mobility Support in IPv6, RFC 3775", ~ (2004)
  12. T. Ernst, "Network Mobility Support Goals and Requirements,IETF draft-ietf-nemo- requirements-05", ~ (2005)
  13. V. Devarapalli, "Network Mobility (NEMO) Basic Support Protocol,IETF RFC3963", ~ (2005)
  14. H.-Y. Lach, "Network mobility in beyond-3G systems", IEEE Communications Magazine, 41(7), pp.52~57 (2003)
  15. J. Abley, "Goals for IPv6 Site-Multihoming Architectures,IETF RFC3582", ~
  16. T. Ernst, "Network Mobility Support Terminology IETF draft-ietf-nemo- terminoloty- 05.txt", ~ (2005)
  17. Won-Tae Kim, "DynaMoNET: Dynamic Multi- homed IPv6 Mobile Networks with multiple Mobile Routers", proceedings of UCS2006, Seoul, Korea, pp.398~413 (2006)
  18. "Bluetooth Special Interest Group (BluetoothSIG)"[URL]
  19. T. Narten, "Neighbor Discovery for IP Version 6 RFC 2461", ~ (1998)
  20. N. Montavont, "Analysis of Multihoming in Mobile IPv6, IETF draft-montavont-mobileip- multihomingpb- statement-05.txt", ~ (2005)
  21. Z.J. Gu, "Mobile IPv6 Extensions to support Nested Mobile Networks", AINA’04, 통권 : 1, pp.488~49 (2004)
  22. Benjie Chen, "Span: An Energy-Efficient Coordination Algorithm for Topology Maintenance in Ad Hoc Wireless Networks", ACM Wireless Networks Journal, 8(5), pp.481~494 (2002)

이 간행물의 다른 논문 (14건)