본문 바로가기
KERD
논문KCI 등재

차세대 인터넷 소개 및 기술 이슈

Next Generation Internet: Introduction and Technical Issues

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

현재 인터넷은 최초로 ARPANET이 설치된 1969년부터 시작하면 초기 TCP/IP 아키텍쳐를 기본으로 해서 40 여년 동안 기본 뼈대를 바꾸지 않고 진화해 왔다. 패킷 스위칭, IP 계층을 thin waist로 하는 유연한 구조, 확장성 있는도메인 이름과 IP 주소의 매핑 등 TCP/IP 아키텍쳐의 장점 덕분에 현재까지는 거의 대부분의 서비스를 잘 지원하고있으나 단말기 이동성, 라우팅 확장성, 보안, 망 관리 등 현재 여러가지 문제점이 대두됨에 따라 새로운 인터넷 아키텍쳐가 필요하다는 주장이 몇 년 전부터 제기되어 왔다. 본 논문에서는 현재 인터넷의 문제점들과 기술적인 이슈들을 분석해 보고 이를 해결하려는 제안된 아키텍쳐들을 소개하며 마지막으로 향후 인터넷의 큰 변화에 대한 개인적인 의견을제시하고자 한다.

Abstract

The TCP/IP architecture of the current Interne has been used for more than 40 years since the inception of initial Internet, ARPANET. The TCP/IP architecture has support almost every kind of Internet services due to its flexible structure such as performing packet switching, using IP as a thin waist, mapping between extendable domain names and IP addresses and so on. However, increasingly more problems are emerging as the Internet becomes the digital infrastructure: mobility support, routing scalability, security, network management and so on. We first analyze the problems and issues of the current Internet. Next we introduce some of the proposals to address the Internet problems by taking a clean slate approach in designing the next generation Internet. Last, we discuss what will impact the next generation Internet and how it will evolve.

참고문헌 (17)

  1. "The Next Generation of the Internet: Revolutionizing the Way We Work, Live, Play, and Learn", Cisco, ~ (2013)
  2. D. Raychaudhuri, "MobilityFirst: A Robust and Trustworthy Mobility Centric Architecture for the Future Internet", ACM SIGMobile Mobile Computing and Communication Review (MC2R), 16(4) (2012)
  3. Lixia Zhang, "Named Data Networking", ACM SIGCOMM Computer Communication Review (CCR) (2014)
  4. V. Jacobson, "Networking Named Content", ACM CoNEXT 2009 (2009)
  5. Dongsu Han, "XIA: Efficient Support for Evolvable Internetworking", NSDI'12 (2012)
  6. Robert Broberg, "The NEBULA Future Internet Architecture", Lecture Notes in Computer Science, 7858, pp.16~26 (2013)
  7. Damien Saucez, "Designing a Deployable Future Internet: The Locator", Identifier Separation Protocol (LISP) Case, 2012, pp.16(6), 14~21
  8. R. Moskowitz, "Host identity protocol", RFC 5201, ~ (2008)
  9. S. Gundavelli, "Proxy mobile IPv6, RFC 5213, Aug. 2008", ~ (2008)
  10. GTPv2 for evolved GPRS, "3rd Generation Partnership Project, 650 Route des Lucioles - Sophia Antipolis, Valbonne - FRANCE, 2009-03", 3GPP TS 29.274 V8.1.0 (2009-03), ~ (2009)
  11. Bhavish Aggarwal, "EndRE: An End-System Redundancy Elimination Service for Enterprises", USENIX NSDI (2010)
  12. Xiaoqiao Meng, "IPv4 Address Allocation and the BGP Routing Table Evolution", ACM SIGCOMM Computer Communication Review, 35(1), pp.s71~s80 (2005)
  13. Geoff Huston, "Securing BGP and SIDR", IETF Journal, 7(1) (2011)
  14. Sooel Son, "The Hitchhiker's Guide to DNS Cache Poisoning", pp.466~483 (2010), Springer
  15. Rob Enns, "Network Configuration Protocol (NETCONF), IETF RFC6241, June 2011", ~ (2011)

관련 논문AI추천

이 간행물의 다른 논문 (12건)