모바일 환경에서 효율적인 멀티캐스트 그룹핑을 위한 노드 조인
Node Join Management of Efficient Multicast Grouping in Mobile Environment
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
IP 멀티캐스트 서비스를 위해 PIM, CBT, DVMRP 등 다양한 라우팅 프로토콜이 연구되고 있다. PIM-SM은 RPT를 이용한 공유트리 방식으로 확장성이 우수한 RP(Randevous Pointer)를 선정하는데, 서비스 시간이 경과함에 따라 네트워크 운영 및 멀티캐스트의 확장으로 인하여 메시지 교환이 증가하여, 네트워크의 가용대역폭을 만족시키지 못한 경우가 발생하게 된다. 본 논문에서는 네트워크의 자원을 절약하고 멀티캐스트 그룹을 효율적으로 관리하기위한 AMGM(Adaptative-Multicast-Grouping- Management) 방식을 제안한다. AMGM은 인접 멀티캐스트 그룹을 병합하는 방식으로 단계적으로 멀티캐스트 그룹의 수를 줄여서 네트워크의 대역폭을 개선시킨다. 기존에 제안된 방식(PIM-SM/PMIPV6)과의 비교를 통해 이 방식의 유효성을 확인하였다.
Abstract
For the IP multicast service, there are some methods researched. The PIM-SM(Protocol Independence Multicast-Sparse Mode), which has a good extensibility and is based on a shared tree scheme using RPT(Randevous Pointer-Tree), When the specified Available Bandwidth is not satisfied by increase the message throughput as Multicast groups and network operations with time. This paper presents a new method called AMGM(Adaptative-Multicast-Grouping-Management) to support multicast grouping for reduce network resources. By merging neighboring multicast groups to reduce the number of multicast group. Through performance analysis and comparison with standard method(PIM-SM/PMIPV6), we certify that this method is pertinent.
참고문헌 (13)
- T. Schmidt, "Multicast Mobility in MIPv6: Problem Statement and Brief Survey" (2008), Internet Draft, IRTF
- S. Gundavelli, "Proxy Mobile IPv6", RFC 5213, ~ (2008)
- Estrin, D., "Protocol independent multicast - sparse mode (pim-sm): Protocol specification", Internet Request for Comments RFC 2117, ~ (1997)
- T. Schmidt, "Base Deployment for Multicast Listener Support in Proxy Mobile IPv6 (PMIPv6) Domains", RFC 6224, ~ (2011)
- Sunguk Choi, "An Effective Scheduling for Multicast Services based on the PMIPv6", DCS, 12(1), pp.11~21 (2011)
- H. Asaeda, "PMIPv6 Extensions for Multicast", draft-asaeda-multimob-pmip6-extension- 05.txt, ~ (2011)
- S. Jeon, "PMIPv6 Multicasting Support using Native Infrastructure", draft-sijeon-multimob-dire ctrouting-pmip6-00.txt, ~ (2011)
- D. Waitzman, "Distance Vector Multicast Routing Protocol", RFC 1075, ~ (1988)
- D. Estrin, "Protocol Independent Multicast – Dense Mode (PIM-DM):Protocol Specification", Proposed Experimental RFC, ~ (1996)
- A. Ballardie, "Core Based Trees (CBT) Multicast Routing Architecture", RFC 2201, ~ (1997)
- D. Estrin, "Protocol Independent Multicast Sparse Mode (PIM-SM): Protocol Specification" (1998), IETF
- Ohanian TA., "Digital nonlinear editing: new approaches to editing film and video" (1993), Focal Press
- 이희상, "효율적인 스트리밍 서비스를 위한 가용대역폭 측정 기법", 정보과학회논문지 : 정보통신, 34(2), pp.100~109 (2007), 한국정보과학회
