Improved STUN Algorithm for Testing Network Address Translation
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
Peer-to-Peer (P2P) network is a group of computers communicating directly with each other without through a central server. P2P network is used for file sharing, multi-player online games, to avoid the expense and delay of traffic at the server. However, P2P communication has problems dealing with Network Address Translation (NAT) traversal. Conventional Simple Traversal of UDP through NATs (STUN) protocol was given to discover the type of NATs behind Clients. In conventional STUN processing, the tests follow the sequence of time that means the first test is needed to get the result before performing the second test and so on. Thus, the system testing has the delay of time. So, in this paper, we propose an improved STUN algorithm that separating tests of the conventional STUN algorithm and perform all tests in parallel. So, the execution time will be shortened significantly. We also have reality experiment in which is applied improved STUN algorithm for testing NATs.
Abstract
Peer-to-Peer (P2P) network is a group of computers communicating directly with each other without through a central server. P2P network is used for file sharing, multi-player online games, to avoid the expense and delay of traffic at the server. However, P2P communication has problems dealing with Network Address Translation (NAT) traversal. Conventional Simple Traversal of UDP through NATs (STUN) protocol was given to discover the type of NATs behind Clients. In conventional STUN processing, the tests follow the sequence of time that means the first test is needed to get the result before performing the second test and so on. Thus, the system testing has the delay of time. So, in this paper, we propose an improved STUN algorithm that separating tests of the conventional STUN algorithm and perform all tests in parallel. So, the execution time will be shortened significantly. We also have reality experiment in which is applied improved STUN algorithm for testing NATs.
참고문헌 (12)
- P. Srisuresh, "IP network address translator (NAT) terminology and considerations", RFC-2663, ~ (1999)
- L. D’Acunto, "A measurement of NAT & firewall characteristics in peer to peer", Proceedings of the ASCI Conference (2009)
- K. Egevang, "The IP network address translator", RFC-1631, ~ (1994)
- P. Srisuresh, "State of Peer-to-peer (P2P) communication across network address translators (NATs)", RFC-5128, ~ (2008)
- Bryan Ford, "Peer-to-peer communication across network address translators", Proceedings of the annual conference on USENIX Annual Technical Conference (2008)
- J. Rosenberg, "STUN-simple traversal of user datagram protocol through network address translators", RFC-3489, ~ (2003)
- NAT traversal in peer-to-peer architecture, "Marc-André Poulin", Carleton University, ~, pp.Technical Report SCE-12-04 (2012)
- A. Mueller, "Behavior and classification of NAT devices and implications for NAT- traversal", IEEE Network Special Issue on Implications and Control of Middleboxes in the Internet (2008)
- A. Mueller, "ANTSA framework for nnowledge based NAT traversal", IEEE globecom next-generation networking and internet symposium (2009)
- Geoff Huston, "Anatomy: A look inside network address translators", The Internet protocol Journal, 7(3), pp.1~40 (2004)
- M. Boucadair, "Universal plug and play(UPnP)internet gateway device-port control protocol interworking function(IGD-PCP IWF)", RFC-6970, ~ (2013)
- Lisa Sherwin, "UPnP specifications named international standard for device interoperability for IP-based network devices", ~ (2009)
