본문 바로가기
KERD
논문KCI 등재

802.11p WAVE에서 단절율을 고려한 양방향 패킷전송 프로토콜 설계

A Two-way Packet Transmission to Reduce Network Fragmentation for 802.11p WAVE

2

조회

0

다운로드

1

인용

0

참고문헌

키워드

주제분류학제간연구

초록

VANET(Vehicular Ad-hoc Network)은 도심 교차로에서 도로의 특성과 차량의 높은 이동성의 영향을 크게 받는다. 차량의 밀도가 충분하지 못한 경우 네트워크가 단절되는 상황이 자주 발생 할 수 있으며, 또한 다음 노드를 찾기 위한 탐욕모드와 복구모드 같은 모드 전환에 따른 노드 수가 증가로 인하여 패킷 전송 지연의 문제가 발생한다. 본 연구에서는 GBSR 프로토콜을 개선하여 순방향으로 패킷을 전달함과 동시에 패킷을 하나 더 복제하여 역방향으로도 전달하는 알고리즘을 제안하였다. 두 배수로 패킷을 전달하므로 한쪽 방향의 패킷이 단절되더라도 다른 한쪽 방향의 패킷이 목적지 노드(destination)에 도달할 수 있으므로 네트워크의 단절이 감소 될 수 있다. 또한 하나의 패킷은 목적지와 가까운 방향으로 전달하고, 또 다른 패킷은 다른 방향으로 전달하므로 차량의 밀도와 상관없이 경로를 선정할 수 있으며 트래픽도 증가하지 않는다.

Abstract

VANET (Vehicular Ad-hoc Network) is largely influenced by the characteristic of the street and the mobility of the vehicles in an inner-city intersection as a network. In this model, an insufficient amount of vehicles can often leads to network connection failure. In addition, there will be increase in the number of nodes secondary to the switching in between different modes in order to find the next node, which can further delay the packet transfer process. In this study, we are proposing a new algorithm by improving the GBSR protocol to transfer a packet in a forward direction and sending the copy in a reverse direction concurrently. Because this method transfers the same packet to two different directions, there will be a decrease in the probability of network failure as even if the packet transferred to one direction fails to deliver, the other packet can still reach the destination via another direction. In addition, the network traffic will not worsen due to the fact one can choose to send a packet in a direction without being influenced by the amount of available vehicles as one copy of the packet will be directed to a shorter distance to the destination while another copy will be directed to a different route.

참고문헌 (12)

  1. B. Karp, "GPSR : Greedy perimeter stateless routing for wireless network", proc. of ACM, 2000, 243~254
  2. "Intelligent transport systems"[URL]
  3. Hyun Yu, "A V2V reliable packet forwarding mechanism for the VANET environment", pp.107~111 (2008), Korea Society for Internet Information
  4. "Wireless Access for Vehicular Environment"[URL]
  5. Hyunhee Jang, "An enhanced greedy message forwarding protocol for high mobile inter-vehicular communications" (2009), The Institue of Electronics and Information Engineers
  6. "Moblie Ad Hoc Network Working Group"[URL]
  7. T. Clausen, "Project Hipercom, INRIA, Optimized link state routing protocol(OLSR)", IETF RFC 3626, ~ (2003)
  8. C. Perkins, "Ad hoc on-demand distance vector (AODV)routing", IETF RFC 3561, ~ (2003)
  9. D. Johnson, "The dynamic source routing protocol", IETF RFC 4728, ~ (2007)
  10. Do-Shik An, "Message delivery schemes in robust of network disconnection for GBSR based VANET routing", pp.137~140 (2009), Korea Multimedia Society
  11. Hyun Yu, "A routing protocol using the density of vehicle on the road for VANET", pp.328~331 (2010), Korean Institute of Information Scientists ad Enginneers
  12. 유현, "도시 환경에서 도로 차량 밀도 정보를 기반으로 하는 VANET 라우팅 프로토콜", 정보처리학회논문지. 컴퓨터 및 통신시스템, 2(6), pp.253~256 (2013), 한국정보처리학회[DOI]

관련 논문AI추천

이 간행물의 다른 논문 (12건)