본문 바로가기
KERD
논문KCI 등재

SRTP, MIKEY, CMS, IPSec, TLS, IPTV에 대한 패딩 오라클 공격 가능성 분석

Analysis of Padding Oracle Attack Possibility about Application Environment; SRTP, MIKEY, CMS, IPSec, TLS, IPTV

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

인터넷상의 다양한 응용환경에서는 개인정보 및 민감한 정보를 보호하기 위해서 안전성이 검증된 암호 알고리즘을 사용한다. 하지만 안전성이 검증된 암호 알고리즘을 사용하여도 주어진 암호 알고리즘을 적용하는 방식이 올바르지 못하면 보호하고자 하는 정보들이 누출될 수 있다는 연구 결과와 공격기법들이 소개되고 있다. 이 공격방법들 중 대표적인 사례가 패딩 오라클 공격이다. 본 논문에서는 블록 암호 기반 CBC운영모드와 CBC 패딩 방법을 적용하는 응용환경인 STRP, MIKEY, CMS, IPSec, TLS, IPTV에 대해 패딩 오라클 공격을 적용하고, 패딩 오라클 공격에 대한 공격 가능 여부 및 취약점에 관하여 연구하였다.

Abstract

In the various application environments on the internet, we use verified cipher algorithm to protect personal information. Even so, if anapplication method isn’t proper, the information you want to keep can be intercepted. One of the representative examples of it is aPADDING ORACLE ATTACK. This thesis studied about STRP, MIKEY, CMS, IPSec, TLS, IPTV, an application environment whichapply CBC operational mode based on block cipher and CBC padding method, and about whether we can attack against the PaddingOracle Attack as well as the vulnerable points.

참고문헌 (15)

  1. S. Vaudenay, "Security Flaws Induced by CBC Padding –Applications to SSL, IPSEC, WTLS...", Eurocrypt 2002, LNCS, 2332, pp.534~545 (2002), Springer-Verlag
  2. Juliano Rizzo, "Practical Padding Oracle Attacks", USENIX WOOT, ~ (2010)
  3. M. Baugher, "The Secure Real-time Transport Protocol (SRTP)", RFC 3711, ~ (2004)
  4. M. Dworkin, "Recommendation for Block Cipher Modes of Operation", NIST 800-38A, ~ (2001)
  5. J-S. Kang, "Provable Security of KASUMI and 3GPP Encryption Mode f8", ASIACRYPT 2001, LNCS 2248, Springer-Verlag, 255~271 (2001)
  6. S. Yoon, "The SEED Cipher Algorithm and Its Use with the Secure Real-Time Transport Protocol (SRTP)", RFC 5669, ~ (2010)
  7. J. Arkko, "MIKEY : Multimedia Internet KEYing", RFC 3830, ~ (2004)
  8. J. Schaad, "Advanced Encryption Standard(AES)Key Wrap Algorithm", RFC 3394, ~ (2002)
  9. J. Jeong, "IANA Registry Update for Support of the SEED Cipher Algorithm in Multimedia Internet KEYing(MIKEY)", RFC 5748, ~ (2010)
  10. J. Park, "Use of the SEED Encryption Algorithm in Cryptographic Message Syntax(CMS)", RFC 4010, ~ (2005)
  11. S. Kent, "Security Architecture for the Internet Protocol", RFC 4301, ~ (2005)
  12. T. Dierks, "The TLS Protocol Version 1. 0", RFC 2246, ~ (1999)
  13. T. Dierks, "The Transpord Layer Security(TLS)Protocol Version 1. 2", RFC 5246, ~ (2008)
  14. Korea Association of Information, "SEED", ARIA scrambling algorithm for IPTVservice Security, 2009
  15. T. Dierks, "The Transport Layer Security(TLS)Protocol Version 1. 1", RFC 4346, ~ (2006)

관련 논문AI추천

이 간행물의 다른 논문 (5건)