본문 바로가기
KERD
논문KCI 등재

프록시 모바일 IPv6 네트워크에서 저비용의 글로벌 이동성관리 기법

LC-GM2: Low-Cost Global Mobility Management Scheme in Proxy Mobile IPv6 Networks

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

본 논문에서는 PMIPv6를 기반으로 하는 LC-GM2라는 저비용의 글로벌 이동성관리 아키텍처와 프로토콜 절차를 제안한다. LC-GM2의 구성은 여러PMIPv6 의 로컬 도메인과 계층적 구조로 코어 네트워크로 연결되어 있다. LC-GM2에서 이동성 관리는 도메인 내에서의 모바일 노드(MN)의 이동은 PMIPv6의 이동성관리 방법으로 수행되며 도메인간으로 이동할 때는 홈 네트워크 모바일 액세스 게이트웨이(MAG)가 이동 네트워크의 지역 모바일 앵커(LMA)에 직접 프록시 바인딩 업데이트(PBU)를 수행하여 코어 네트워크(CN)의 게이트웨이를 통한 패킷 전송을 수행하는 네트워크 엔티티 관점으로 수행된다. 분석 모델로 유체 흐름 이동성 모델을 기반으로 위치 업데이트 비용, 패킷 전달 및 총 비용 함수의 다양한 시스템 매개변수의 영향 이용하여 계층적 모바일 IPv6(HMIPv6) 이동성관리 프로토콜과 GPMIP 아키텍처와 비교・분석한다. 수학적 분석의 결과는 다른 글로벌 이동성관리 기법들 간의 비용 분석의 결과를 통하여 제안된 글로벌 이동성관리 기법(LC-GM2)이 전체적인 비용측면에서 상당히 우수하다는 것을 보여준다.

Abstract

This paper specifies a low-cost global mobility management architecture and protocol procedure called LC-GM2, which is based on Proxy Mobile IPv6. In LC-GM2, mobility management is performed by the network entity. The benefit is the elimination of the wireless link data delivery tunnel overhead between a mobile node and the access router. To compare with the well-known Hierarchical Mobile IPv6 mobility management protocol and GPMIP, the location update, packet delivery, and total cost functions generated by a mobile node during its average domain residence time are formulated for each protocol based on Fluid-flow mobility model. Then, the impacts of various system parameters on the cost functions are analyzed. The analytical results indicate that the proposed global mobility management protocol can guarantee lower total costs.

참고문헌 (17)

  1. D. Johnson D, "Mobility support in IPv6", IETF RFC 3775, ~ (2004)
  2. Soliman H, "Hierarchical Mobile IPv6 Mobility Management (HMIPv6)", IETF RFC 4140, ~ (2005)
  3. Gundavelli S, "Proxy mobile IPv6", IETF RFC 5213, ~ (2008)
  4. Patel A, "Mobile node identifier option formobile IPv6 (MIPv6)", IETF RFC 4283, ~ (2005)
  5. Droms R, "Dynamic host configuration protocol for IPv6(DHCPv6)", IETF RFC 3315, ~ (2007)
  6. T. Narten, "Neighbor Discovery for IP Version 6(IPv6)", IETF RFC 2461, ~ (1998)
  7. Sarikaya B, "DHCPv6 based home network Prefix delegation for PMIPv6", draft-sarikaya-netlmmprefix- delegation-01, ~ (2007)
  8. Huachun Zhou, "A Proxy Mobile IPv6 Based Global Mobility Management Architecture and Protocol", Mobile Netw Appl, 15, pp.530~542 (2009)
  9. Troan O, "IPv6 prefix Options for Dynamic Host Configuration Protocol (DHCP) version 6", IETF RFC 3633, ~
  10. Lior A, "RADIUS mobile IPv6 support", IETF draft-ietf-mip6-radius-03, ~ (2009)
  11. Vixie P, "Dynamic updates in the Domain Name System (DNS UPDATE)", IETF RFC 2136, ~ (1997)
  12. 송문배, "A comparative analysis on the signaling load of Mobile IPv6 and Hierarchical Mobile IPv6: Analytical approach", IEICE TRANSACTIONS ON INFORMATION AND SYSTEMS, E89D(1), pp.139~149, IEICE-INST ELECTRONICS INFORMATION COMMUNICATIONS ENG
  13. Zhang X, "P-MIP: Paging extensions for mobile IP", ACM, pp.7(2), 127~141
  14. 백상헌, "A study on performance of hierarchical mobile IPv6 in IP-based cellular networks", IEICE TRANSACTIONS ON COMMUNICATIONS, E87B(3), pp.462~469, IEICE-INST ELECTRONICS INFORMATION COMMUNICATIONS ENG
  15. 한연희, "Mobility management for all-IP mobile networks: Mobile IPv6 vs. Proxy Mobile IPv6", IEEE WIRELESS COMMUNICATIONS, 15, pp.36~45, IEEE-INST ELECTRICAL ELECTRONICS ENGINEERS INC
  16. "Seamless Wireless Connectivity for Multimedia Services in High Speed Trains Karimi, O.B.; Jiangchuan Liu; Chonggang Wang Selected Areas in Communications", IEEE Journal, 30(4), pp.729~739 (2012)
  17. Leo Yi, "A comparative study of WiMAX and LTE as the next generation mobile enterprise network", Advanced Communication Technology (ICACT), 2011 13th International Conference on Publication Year, pp.654~658 (2011)

관련 논문AI추천

이 간행물의 다른 논문 (12건)