본문 바로가기
KERD
논문KCI 등재

저전력 네트워크 기반의 확장 용이한 스마트 홈 IoT 시스템

An Extensible Smart Home IoT System Based on Low-power Networks

2

조회

0

다운로드

2

인용

0

참고문헌

키워드

초록

There are increasing interests on smart home systems. However, most of the existing works focus on the functionality itself. In this paper, we propose an extensible smart home system based on low power networking such as CoAP, 6LoWPAN, and Zigbee. The proposed home IoT system consists of Home APP, Home Server, Home Broker, and Power Devices. Each component of the system is connected by the low-power network technologies aforementioned. As the end device, Power Device senses the current consumption of the attached appliance and controls the power to it. Power Device reports the sensing data to Home Server via Home Broker. The Home Broker enhances the scalability of the system. Home Broker extends the service area and the user's services, and it manages the connection of the underlying devices and processes, and transmits data to Home Server from Power Devices. Through the experimental evaluation, we show that the proposed system achieves the design goals such as extensibility and low power networking.

Abstract

There are increasing interests on smart home systems. However, most of the existing works focus on the functionality itself. In this paper, we propose an extensible smart home system based on low power networking such as CoAP, 6LoWPAN, and Zigbee. The proposed home IoT system consists of Home APP, Home Server, Home Broker, and Power Devices. Each component of the system is connected by the low-power network technologies aforementioned. As the end device, Power Device senses the current consumption of the attached appliance and controls the power to it. Power Device reports the sensing data to Home Server via Home Broker. The Home Broker enhances the scalability of the system. Home Broker extends the service area and the user's services, and it manages the connection of the underlying devices and processes, and transmits data to Home Server from Power Devices. Through the experimental evaluation, we show that the proposed system achieves the design goals such as extensibility and low power networking.

참고문헌 (22)

  1. J. Gubbi, "Internet of Things (IoT): A Vision, Architectural Elements, and Future Directions", Future Generation Computer Systems, 29(7), pp.1645~1660 (2013)[DOI]
  2. M. Kong, "Trend and prospects of Internet of Things(IoT)", Journal of Korea Design Knowledge, 56(2), pp.32~36 (2016)
  3. D.G. Nam, "The Development of Internet of Intelligent Things and Future Service Model", Journal of the Korean Institute of Communication Sciences, 27(7), pp.3~9 (2010)
  4. T.M. Lee, "AND-OLSR: Adaptive OLSR Protocol Based on Average Node Distance in Dispersion Falling Mobility Model"
  5. S. Min, "G-eye: Route Guide System Based on Obstacle Map for Blind people", Proceedings of HCI Society of Korea, pp.703~705 (2017)
  6. S.E. Yoo, "Technological Advances in Wireless Sensor Networks Enabling Diverse Internet of Things Applications", International Journal of Distributed Sensor Networks, 14(3) (2018)
  7. 이진해, "개방형 하드웨어 플랫폼 기반의 확장 용이한 스마트 홈 IoT 시스템", 대한임베디드공학회논문지, 11(6), pp.369~377 (2016), 대한임베디드공학회[DOI]
  8. G. Montenegro, "Transmission of IPv6 Packets Over IEEE 802.15.4 Networks, No. RFC 4944", ~ (2007)
  9. Z. Shelby, "Constrained Application Protocol (CoAP), No. RFC 7252", ~ (2014)
  10. S.K. Ko, "The Latest Standard Technology of IETF CoAP", OSIA Standards & Technology Review, 28(4), pp.74~86 (2015)
  11. JINWENQUAN, "상호 호환성 검증을 위한 IoT 기반의 CoAP 프로토콜 구현 및 실험", 한국인터넷방송통신학회 논문지, 14(4), pp.7~12 (2014), 한국인터넷방송통신학회[DOI]
  12. K.H. Kim, "Low-Power Sensor Network (6lowpan) Technology Based on IEEE 802.15.4", Communications of the Korean Institute of Information Scientists and Engineers, 25(12), pp.60~65 (2007)
  13. D.S. Moon, "Design and Implementation of Home Network System Based on CoAP", 6LoWPAN, 2017, 1340~1342
  14. 김철민, "BLE 네트워크 상에서 사물인터넷 서비스 제공을 위한 CoAP과 6LoWPAN 구현", 방송공학회 논문지, 21(3), pp.298~306 (2016), 한국방송∙미디어공학회[DOI]
  15. S.J. Lee, "Analyze the Differences in per Second of Transfer Processing Amount Between the HTTP Protocol and CoAP Protocol", Proceedings of Korean Institute of Information Scientists and Engineers, pp.1838~1840 (2015)
  16. K. Hartke, "Observing Resources in the Constrained Application Protocol (CoAP), No. RFC 7641", ~ (2015)
  17. "MCU Wireless AT86RF233 Datasheet", Ateml, ~
  18. "CYW43143 Datasheet", ~
  19. "Digi XBee S1 802.15.4 RF Modules datasheet", Digi, ~

관련 논문AI추천

이 간행물의 다른 논문 (6건)