The development of a ship’s network monitoring system using SNMP based on standard IEC 61162-460
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
In this study, a network monitoring system, including a secure 460-Network and a 460-Gateway, is designed and developed according with the requirements of the IEC (International Electro-Technical Commission) 61162-460 network standard for the safety and security of networks on board ships. At present, internal or external unauthorized access to or malicious attack on a ship’s on board systems are possible threats to the safe operation of a ship’s network. To secure the ship’s network, a 460-Network was designed and implemented by using a 460-Switch, 460-Nodes, and a 460-Gateway that contains firewalls and a DMZ (Demilitarized Zone) with various application servers. In addition, a 460-firewall was used to block all traffic from unauthorized networks. 460-NMS (Network Monitoring System) is a network-monitoring software application that was developed by using an simple network management protocol (SNMP) SharpNet library with the .Net 4.5 framework and a backhand SQLite database management system, which is used to manage network information. 460-NMS receives network information from a 460-Switch by utilizing SNMP, SNMP Trap, and Syslog. 460-NMS monitors the 460-Network load, traffic flow, current network status, network failure, and unknown devices connected to the network. It notifies the network administrator via alarms, notifications, or warnings in case any network problem occurs. Once developed, 460-NMS was tested both in a laboratory environment and for a real ship network that had been installed by the manufacturer and was confirmed to comply with the IEC 61162-460 requirements. Network safety and security issues onboard ships could be solved by designing a secure 460-Network along with a 460-Gateway and by constantly monitoring the 460-Network according to the requirements of the IEC 61162-460 network standard.
Abstract
In this study, a network monitoring system, including a secure 460-Network and a 460-Gateway, is designed and developed according with the requirements of the IEC (International Electro-Technical Commission) 61162-460 network standard for the safety and security of networks on board ships. At present, internal or external unauthorized access to or malicious attack on a ship’s on board systems are possible threats to the safe operation of a ship’s network. To secure the ship’s network, a 460-Network was designed and implemented by using a 460-Switch, 460-Nodes, and a 460-Gateway that contains firewalls and a DMZ (Demilitarized Zone) with various application servers. In addition, a 460-firewall was used to block all traffic from unauthorized networks. 460-NMS (Network Monitoring System) is a network-monitoring software application that was developed by using an simple network management protocol (SNMP) SharpNet library with the .Net 4.5 framework and a backhand SQLite database management system, which is used to manage network information. 460-NMS receives network information from a 460-Switch by utilizing SNMP, SNMP Trap, and Syslog. 460-NMS monitors the 460-Network load, traffic flow, current network status, network failure, and unknown devices connected to the network. It notifies the network administrator via alarms, notifications, or warnings in case any network problem occurs. Once developed, 460-NMS was tested both in a laboratory environment and for a real ship network that had been installed by the manufacturer and was confirmed to comply with the IEC 61162-460 requirements. Network safety and security issues onboard ships could be solved by designing a secure 460-Network along with a 460-Gateway and by constantly monitoring the 460-Network according to the requirements of the IEC 61162-460 network standard.
참고문헌 (18)
- "“The Guidelines on Cyber Security onboard Ships,” BIMCO Bagsvaerdvej 161 Denmark, 2880 Bagsvaerd, Version 1.1" (2016)[URL]
- O. J. Rodseth, "Design challenges and decisions for a new ship data network", ISIS 2011 (2011)
- "ISO 16425-CD: Ships and marine technology Installation guideline for ship communication network of improving communication for shipboard equipment and systems (Committee Draft), 2012. ISO/TC 8/SC 6" (2013)[URL]
- "IEC TECHNICAL COMMITTEE 80: MARITIME NAVIGATION AND RADIOCOMMUNICATION EQUIPMENT AND SYSTEMS"[URL]
- "IEC 61162-450: Maritime navigation and radio communication equipment and systems - Digital interfaces - Part 450: Multiple talkers and multiple listeners - Ethernet interconnection, first edition" (2011)[URL]
- "IEC 61162-460: Maritime navigation and radio communication equipment and systems - Digital interfaces - Part 460: Multiple talkers and multiple listeners – Ethernet interconnection - Safety and Security" (2015)[URL]
- "ISOC RFC 791: Internet Protocol (IP), Standard STD0005 (and updates)"[URL]
- "CISCO CATALYST 3560 SERIES SWITCHES"[URL]
- "“the FortiGate Cookbook 5.2”, FortiGate/FortiOS, FortiGate 5.2.0" (2015)[URL]
- W. Barth, "Nagios: System and Network Monitoring" (2008), William Pollock
- "ISOC RFC 5424: The Syslog Protocol"[URL]
- A. Ghoda, "Windows 8 MVVM Patterns are Revealed: covers both C# and JavaScript" (2013), Apress
- S. Haldar, "SQLite Database System Design and Implementation, Version 1" (2015), Self-publisher
- M. Michaelis, "Essentials C# 6.0" (2015), Addison-Wesley Professional
- "NET-SNMP, current release: 5.7.3"[URL]
- "ISOC RFC 3418: Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)"[URL]
- "ISOC RFC 3411: An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks"[URL]
- Z. X. Wu, "Ship’s network security and monitoring system using SNMP", Proceedings of the ISMT 2016, pp.74~ (2016)
